TYPO3-CORE-SA-2021-008: Cross-Site Scripting in Content Preview

Problem Description

It has been discovered that content elements of type menu are vulnerable to cross-site scripting when their referenced items get previewed in the page module. A valid backend user account is needed to exploit this vulnerability.

The affected code is only executed if an extension is used that actually leverages the type menu. By default this is not available by the Core.

Solution

Update to TYPO3 versions 7.6.51, 8.7.40, 9.5.25, 10.4.14, 11.1.1 that fix the problem described.

Credits

Thanks to TYPO3 contributor Oliver Bartsch who reported and fixed the issue.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

General Note

All security related code changes are tagged so that you can easily look them up in our review system.

Zurück