TYPO3-EXT-SA-2019-020: CSRF in extension "Change password for frontend users" (fe_change_pwd)

  • Release Date: December 17, 2019
  • Component Type: Third party extension. This extension is not a part of the TYPO3 default installation.
  • Vulnerability Type: Cross-Site-Request-Forgery
  • Affected Versions: 1.4.1 and below
  • Severity: Medium
  • Suggested CVSS v3.1: AV:N/AC:H/PR:N/UI:R/S:U/C:H/I:L/A:N/E:F/RL:O/RC:C
  • CVE: Not assigned yet

Problem Description

The extension fails to implement a CSRF protection for update password action.

Solution

An updated version 1.5.0 is available from the TYPO3 extension manager, Packagist and at

https://extensions.typo3.org/extension/download/fe_change_pwd/1.5.0/zip/

Users of the extension are advised to update the extension as soon as possible.

Note: In case template Edit.html has been modified individually, you must add <f:form.hidden property="changeHmac" /> right after the <f:form> tag in your template.

Credits

Credits go to Security Team Member Torben Hansen who discovered and reported the vulnerability.

General Advice

Follow the recommendations that are given in the TYPO3 Security Guide. Please subscribe to the typo3-announce mailing list.

Zurück